StarCluster - Mailing List Archive

Re: SSH Does Not Start On Custom AMI

From: Petit III, Robert A. <no email>
Date: Mon, 8 Dec 2014 16:37:12 +0000

Hi Hugh,

I'm unable to login as ubuntu, connection is being refused for some reason or another. My guess is it isn't starting up fully. Maybe I'll create an AMI with out messing with sshd_config and fstab see if that works.

I'll keep you posted.

Thanks for the suggestions,
Robert

________________________________
From: MacMullan, Hugh [hughmac_at_wharton.upenn.edu]
Sent: Monday, December 08, 2014 10:17 AM
To: Petit III, Robert A.; starcluster_at_mit.edu
Subject: RE: SSH Does Not Start On Custom AMI

Hi Robert:

Can you ssh into the instance you tried to start as 'ubuntu' user (ssh -i path/to/your/key.pem ubuntu_at_ec2-someDNSname.amazon.com<mailto:ubuntu_at_ec2-someDNSname.amazon.com>)? But not 'root_at_ec2'? I've seen this after updates when the /etc/cloud/cloud.cfg gets changed to 'disable_root: true'. Change it to 'false' and ebsimage it again might work for you.

-Hugh

From: starcluster-bounces_at_mit.edu [mailto:starcluster-bounces_at_mit.edu] On Behalf Of Petit III, Robert A.
Sent: Monday, December 08, 2014 10:06 AM
To: starcluster_at_mit.edu
Subject: [StarCluster] SSH Does Not Start On Custom AMI

Hello All,

Following guidlines in the manual (starcluster start -o ) I created a custom AMI based on ami-52a0c53b (us-east-1 starcluster-base-ubuntu-12.04-x86_64-hvm (HVM-EBS)) using StarCluster 0.96.6 on a c3.large instance. When I launch a cluster using this AMI it just hangs at 'waiting for SSH to come up' and eventually just dies there.

For my custom AMI I did the following (all as root, via sshmaster):

  * updated Ubuntu 12.04 packages
  * installed packages my app required
  * installed python and R libraries
  * setup S3FS-Fuse and added FSTAB entry
  * modified sshd_config to allow password logins
This instance runs fine, I can stop, restart, reboot, etc.. and everything is fine. Only when I create the AMI does it stop working, I've tried creating the AMI from starcluster ebsimage as well as from the AWS management console.

I realize I can just create plugins to make these changes, but I'm curious if others have run into this issue.

Thank you very much,
Robert

________________________________

This e-mail message (including any attachments) is for the sole use of
the intended recipient(s) and may contain confidential and privileged
information. If the reader of this message is not the intended
recipient, you are hereby notified that any dissemination, distribution
or copying of this message (including any attachments) is strictly
prohibited.

If you have received this message in error, please contact
the sender by reply e-mail message and destroy all copies of the
original message (including attachments).
Received on Mon Dec 08 2014 - 11:37:16 EST
This archive was generated by hypermail 2.3.0.

Search:

Sort all by:

Date

Month

Thread

Author

Subject